aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-08-07 13:05:52 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-08-07 13:05:52 +0000
commit9e6c7784ea8227ce371f89ff3f069692d26ef5b8 (patch)
treec25ea46a47761d22e7370e398449504ec93edce0 /CMakeLists.txt
parentMerge pull request #4129 (diff)
downloadmonero-9e6c7784ea8227ce371f89ff3f069692d26ef5b8.tar.xz
CMakeLists.txt: add -mmitigate-rop to security flags if found
This is GCC/x86/x86_64 only
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cab853581..346b2592e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,6 +572,9 @@ else()
add_c_flag_if_supported(-fstack-protector-strong C_SECURITY_FLAGS)
add_cxx_flag_if_supported(-fstack-protector-strong CXX_SECURITY_FLAGS)
+ add_c_flag_if_supported(-mmitigate-rop C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-mmitigate-rop CXX_SECURITY_FLAGS)
+
# linker
if (NOT WIN32)
# Windows binaries die on startup with PIE