aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-09-25 12:06:20 +0200
committerRiccardo Spagni <ric@spagni.net>2018-09-25 12:06:20 +0200
commitd2f9a4c584cfd072487dbd2503954049f6e0959c (patch)
treefbf375eb60b664d32360e716d72151cfc90f1f0f /CMakeLists.txt
parentMerge pull request #4419 (diff)
parentFix Darwin Sodium build (diff)
downloadmonero-d2f9a4c584cfd072487dbd2503954049f6e0959c.tar.xz
Merge pull request #4420
0f4f873b Fix Darwin Sodium build (TheCharlatan) bf1e1d97 A Travis to monero (TheCharlatan)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b5a38509..994d47691 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -874,7 +874,7 @@ elseif(DRAGONFLY)
set(EXTRA_LIBRARIES execinfo ${COMPAT})
elseif(CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
set(EXTRA_LIBRARIES socket nsl resolv)
-elseif(NOT MSVC)
+elseif(NOT MSVC AND NOT DEPENDS)
find_library(RT rt)
set(EXTRA_LIBRARIES ${RT})
endif()