aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-10-05 17:04:41 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-10-06 08:47:03 +0100
commit27fdaaa4097fa4b5b13d63b65bf6b5d45e08fc81 (patch)
treefc2e8af79bf74b0a1d7fbf96adbcdc0c83103f33 /CMakeLists.txt
parentMerge pull request #2518 (diff)
downloadmonero-27fdaaa4097fa4b5b13d63b65bf6b5d45e08fc81.tar.xz
Fix building with -DARCH=default -DNO_AES=ON
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f74f59e3..9a2310f3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -452,7 +452,11 @@ else()
option(NO_AES "Explicitly disable AES support" ${NO_AES})
- if(NOT NO_AES AND NOT ARM AND NOT PPC64LE)
+ if(NO_AES)
+ message(STATUS "AES support explicitly disabled")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_AES")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DNO_AES")
+ elseif(NOT ARM AND NOT PPC64LE)
message(STATUS "AES support enabled")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")