aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-06-21 20:08:10 -0400
committerredfish <redfish@galactica.pw>2016-06-21 22:32:55 -0400
commitc6501607f3ba712f10864192f1c3c62a5f25e7bf (patch)
tree919cd2bb741d5a37223ef12c5ce758d4951d4d28 /CMakeLists.txt
parentcmake: initialize ARCH for native builds (diff)
downloadmonero-c6501607f3ba712f10864192f1c3c62a5f25e7bf.tar.xz
cmake: disable AES on ARM
On ARM, gcc fails with 'unknown argument' if passed '-maes'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1770b229f..f7c932585 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -339,10 +339,12 @@ else()
option(NO_AES "Explicitly disable AES support" ${NO_AES})
- if (NOT NO_AES)
+ if(NOT NO_AES AND NOT (ARM6 OR ARM7))
message(STATUS "AES support enabled")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
+ elseif(ARM7 OR ARM6)
+ message(STATUS "AES support disabled (not available on ARM)")
else()
message(STATUS "AES support disabled")
endif()