aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfluffypony <ric@spagni.net>2014-09-10 20:01:30 +0200
committerfluffypony <ric@spagni.net>2014-09-10 20:01:30 +0200
commit8d8b47e69f6bd1cfbd8f94c8ffc30b0ad3f19fc0 (patch)
tree063662186142e644d1b48afd213a8e800792da1d /CMakeLists.txt
parentminiupnpc includes fixed (diff)
downloadmonero-8d8b47e69f6bd1cfbd8f94c8ffc30b0ad3f19fc0.tar.xz
more dynamic miniupnp fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9614d7028..3b07a96eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,14 @@ if (UNIX AND NOT APPLE)
find_package(Threads)
endif()
+if(MINIUPNP_FOUND AND MINIUPNPC_VERSION_1_7_OR_HIGHER)
+ add_definitions("-DUPNP_DYNAMIC")
+ set(UPNP_LIBRARIES "miniupnpc")
+else()
+ add_definitions("-DUPNP_STATIC")
+ set(UPNP_LIBRARIES "upnpc-static")
+endif()
+
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")