aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2014-12-06 15:47:49 +0000
committerwarptangent <warptangent@inbox.com>2015-01-04 19:39:40 -0800
commit0886183568a41b41c83e9cd7f624de295d8367c3 (patch)
tree2a492f2a9c064152053e20dea319e83714df54f2 /CMakeLists.txt
parentextraneous semicolon in Blockchain::complete_timestamps_vector (diff)
downloadmonero-0886183568a41b41c83e9cd7f624de295d8367c3.tar.xz
build: add liblmdb to the cmake autodetection system
update for rebase (warptangent 2015-01-04) src/cryptonote_core/CMakeLists.txt (edit) - replace LMDB_LIBRARIES with LMDB_LIBRARY set from autodetection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 000a18df6..ee5d5f2ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,8 +138,8 @@ link_directories(${UNBOUND_LIBRARY_DIRS})
# Final setup for rapidjson
include_directories(external/rapidjson)
-# TODO: make this find lmdb similarly to how unbound and boost are handled
-set(LMDB_LIBRARIES "-llmdb")
+find_package(LMDB REQUIRED)
+include_directories(${LMDB_INCLUDE})
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")