aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2019-04-18 22:04:11 +0200
committerRiccardo Spagni <ric@spagni.net>2019-04-18 22:04:11 +0200
commit71c6b248935ca17af6a5c62f6de05670301861a2 (patch)
tree7809cb8c013c655388b18e8754cd0d2eb3e298a9 /CMakeLists.txt
parentMerge pull request #5463 (diff)
parentWindows: work around a boost 1.70 and cmake SNAFU (diff)
downloadmonero-71c6b248935ca17af6a5c62f6de05670301861a2.tar.xz
Merge pull request #5464
0f52fe4c Windows: work around a boost 1.70 and cmake SNAFU (iDunk5400) b414b69f Windows: fix a build error in MSYS2 with boost 1.70.0 (iDunk5400)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f40021764..c19c9dba7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -878,6 +878,7 @@ set(OLD_LIB_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES})
if(STATIC)
if(MINGW)
set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+ set(Boost_NO_BOOST_CMAKE ON)
endif()
set(Boost_USE_STATIC_LIBS ON)