aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2019-05-14 15:52:32 -0500
committerluigi1111 <luigi1111w@gmail.com>2019-05-14 15:52:32 -0500
commit1fc1c7318cadce0ce3e27e525b443a763fb292dc (patch)
tree5dd0a51b15b8481b1cc28b8a6103245936e59fbb /CMakeLists.txt
parentMerge pull request #5512 (diff)
parentmlog: default to not showing SSL errors (diff)
downloadmonero-1fc1c7318cadce0ce3e27e525b443a763fb292dc.tar.xz
Merge pull request #5519
b8b957d cmake: fix incorrect hint for OPENSSL_ROOT_DIR (moneromooo-monero) 367bb80 mlog: default to not showing SSL errors (moneromooo-monero)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c19c9dba7..037b9cb50 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -898,9 +898,9 @@ elseif(Boost_FOUND)
set(BOOST_BEFORE_1_62 true)
endif()
if (BOOST_BEFORE_1_62)
- message(FATAL_ERROR "Boost older than 1.62 is too old to link with OpenSSL 1.1 or newer. "
+ message(FATAL_ERROR "Boost ${Boost_VERSION} (older than 1.62) is too old to link with OpenSSL ${OPENSSL_VERSION} (1.1 or newer) found at ${OPENSSL_INCLUDE_DIR} and ${OPENSSL_LIBRARIES}. "
"Update Boost or install OpenSSL 1.0 and set path to it when running cmake: "
- "cmake -DOPENSSL_ROOT_DIR='/usr/include/openssl-1.0;/usr/lib/openssl-1.0'")
+ "cmake -DOPENSSL_ROOT_DIR='/usr/include/openssl-1.0'")
endif()
endif()