aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-11-30 03:25:11 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-05-21 22:00:08 +0100
commitc62ddad29e57e5c7c535e860bc58db503bfcd8b7 (patch)
treea78a4761c5be2399a869830d8360724784a95e06 /CMakeLists.txt
parenttranslations: use host compiler (diff)
downloadmonero-c62ddad29e57e5c7c535e860bc58db503bfcd8b7.tar.xz
https://sourceware.org/bugzilla/show_bug.cgi?id=25210v0.16.0.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 882bc96c5..2cb9c0406 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -716,11 +716,6 @@ else()
CHECK_CXX_ACCEPTS_FLAG(-mfloat-abi=softfp CXX_ACCEPTS_MFLOAT_SOFTFP)
endif()
- if(ARM8)
- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-835769 CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-843419 CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
- endif()
-
if(ARM6)
message(STATUS "Selecting VFP for ARMv6")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpu=vfp")
@@ -757,20 +752,6 @@ else()
endif()
endif(ARM7)
- if(ARM8)
- if(CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
- message(STATUS "Enabling Cortex-A53 workaround 835769")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-835769")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-835769")
- endif()
-
- if(CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
- message(STATUS "Enabling Cortex-A53 workaround 843419")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-843419")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-843419")
- endif()
- endif(ARM8)
-
endif(ARM)
if(ANDROID AND NOT BUILD_GUI_DEPS STREQUAL "ON" OR IOS)