aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2019-06-11 18:13:09 -0500
committerluigi1111 <luigi1111w@gmail.com>2019-06-11 18:13:09 -0500
commitc48722caa9166b6fd646778dfefd71d1f131193f (patch)
tree07636263c3f2b2f84ec5e969e2dfe2786e7c39c6 /CMakeLists.txt
parentMerge pull request #5583 (diff)
parentcmake: do not use -mmitigate-rop on GCC >= 9.1 (diff)
downloadmonero-c48722caa9166b6fd646778dfefd71d1f131193f.tar.xz
Merge pull request #5613
2cbe756 p2p: fix GCC 9.1 crash (moneromooo-monero) 35c20c4 Fix GCC 9.1 build warnings (moneromooo-monero) e284889 cmake: do not use -mmitigate-rop on GCC >= 9.1 (moneromooo-monero)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 037b9cb50..6a22478e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -672,8 +672,11 @@ else()
add_cxx_flag_if_supported(-fstack-clash-protection CXX_SECURITY_FLAGS)
endif()
- add_c_flag_if_supported(-mmitigate-rop C_SECURITY_FLAGS)
- add_cxx_flag_if_supported(-mmitigate-rop CXX_SECURITY_FLAGS)
+ # Removed in GCC 9.1 (or before ?), but still accepted, so spams the output
+ if (NOT (CMAKE_C_COMPILER_ID STREQUAL "GNU" AND NOT CMAKE_C_COMPILER_VERSION VERSION_LESS 9.1))
+ add_c_flag_if_supported(-mmitigate-rop C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-mmitigate-rop CXX_SECURITY_FLAGS)
+ endif()
# linker
if (NOT WIN32)