aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-03-29 09:03:30 -0400
committerThomas Winget <tewinget@gmail.com>2015-03-29 09:03:30 -0400
commite7391a411372cabbefe3fd46ba667c21cf1fa3b6 (patch)
tree3934f69a876d5f10637c93fc868d5a8f139aa164 /CMakeLists.txt
parentMerge upstream updates into blockchain branch (diff)
parentSteps toward multiple dbs available -- working (diff)
downloadmonero-e7391a411372cabbefe3fd46ba667c21cf1fa3b6.tar.xz
Merge BerkeleyDB blockchain db implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2b553d92..92f8381cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -177,6 +177,9 @@ include_directories(external/rapidjson)
# Final setup for liblmdb
include_directories(${LMDB_INCLUDE})
+# Final setup for Berkeley DB
+include_directories(${BDB_INCLUDE})
+
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")