aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-09-18 02:52:57 +0200
committerTheCharlatan <seb.kung@gmail.com>2018-09-18 02:52:57 +0200
commit423973596ba6ce645bc578bbc4774023caa335c6 (patch)
treee3d588422e1219dbc8dfc1de6ae8ae2119dbd80b /CMakeLists.txt
parentFix Windows build (diff)
downloadmonero-423973596ba6ce645bc578bbc4774023caa335c6.tar.xz
Fixup 32bit arm build
Set the architecture in the toolchain file correctly
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0de82b436..e62179e18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -495,7 +495,9 @@ if(MSVC)
else()
include(TestCXXAcceptsFlag)
if (NOT ARM6)
- set(ARCH native CACHE STRING "CPU to build for: -march value or 'default' to not pass -march at all")
+ if(NOT DEPENDS OR DEPENDS AND NOT ARM)
+ set(ARCH native CACHE STRING "CPU to build for: -march value or 'default' to not pass -march at all")
+ endif()
endif()
message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")
if(ARCH STREQUAL "default")