aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2017-04-24 10:46:23 +0200
committerRiccardo Spagni <ric@spagni.net>2017-04-24 10:46:23 +0200
commit865bb03ecf01226a488a9cf55bbe848755afe09c (patch)
tree3f72b458473d5173af8f78b6049776d2438f30c4 /CMakeLists.txt
parentMerge pull request #1967 (diff)
parentFix obsolete OpenSSL API usage (diff)
downloadmonero-865bb03ecf01226a488a9cf55bbe848755afe09c.tar.xz
Merge pull request #1968
5e5b8512 Fix obsolete OpenSSL API usage (hyc) 6c72d6a0 Fix Android recognition (hyc) e65d66fe Fix ARM64 identification (hyc) a4673218 Clean up ARMv8-a aes_expand_key() (hyc) a3d77901 Fix block_longhash_worker thread (hyc)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ceebd49ef..d584e41c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,9 +80,10 @@ if (ARM_TEST STREQUAL "arm")
endif()
endif()
-if (ARM_ID STREQUAL "aarch64" OR ARM_ID STREQUAL "arm64")
+if (ARM_ID STREQUAL "aarch64" OR ARM_ID STREQUAL "arm64" OR ARM_ID STREQUAL "armv8-a")
set(ARM 1)
set(ARM8 1)
+ set(ARCH "armv8-a")
endif()
if(WIN32 OR ARM)