aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Vickio <chris@vickio.net>2017-01-14 13:49:04 +0300
committerChris Vickio <chris@vickio.net>2017-01-15 19:23:33 +0300
commitd561f4ad92db6794f6571f5a191041bad65f063b (patch)
tree86c301844f2beec57e6cb4c35ad3e66a91f2e8ad /CMakeLists.txt
parentremove std::move from return statements (pessimizing-move warning) (diff)
downloadmonero-d561f4ad92db6794f6571f5a191041bad65f063b.tar.xz
enable clang checks that were disabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e42cdb384..843f88c87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -350,7 +350,6 @@ else()
set(WARNINGS_AS_ERRORS_FLAG "-Werror")
endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- set(WARNINGS "${WARNINGS} -Wno-deprecated-register -Wno-error=mismatched-tags -Wno-error=null-conversion -Wno-overloaded-shift-op-parentheses -Wno-error=shift-count-overflow -Wno-error=tautological-constant-out-of-range-compare -Wno-error=unused-private-field -Wno-error=unneeded-internal-declaration")
if(ARM)
set(WARNINGS "${WARNINGS} -Wno-error=inline-asm")
endif()