aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriDunk5400 <iDunk5400@users.noreply.github.com>2016-09-10 22:56:40 +0200
committeriDunk5400 <iDunk5400@users.noreply.github.com>2016-09-10 22:56:40 +0200
commit1855213c8fb8f8727f4107716aab8e7ba826462b (patch)
treecf06498f6f76a4f724e704367ad0a4751dcf8cc7 /CMakeLists.txt
parentMerge pull request #1053 (diff)
downloadmonero-1855213c8fb8f8727f4107716aab8e7ba826462b.tar.xz
Attempt to fix broken compilation on some systems caused by #1074
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b0ce5a4e..1f6c9f8d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -502,12 +502,15 @@ else()
# -DCHOST=... or -DCMAKE_AR=... and -DCMAKE_RANLIB=...
if (DEFINED CHOST)
set(CHOST_PREFIX "${CHOST}-")
- endif()
- if (NOT DEFINED CMAKE_AR)
- set(CMAKE_AR "${CHOST_PREFIX}gcc-ar")
- endif()
- if (NOT DEFINED CMAKE_RANLIB)
- set(CMAKE_RANLIB "${CHOST_PREFIX}gcc-ranlib")
+ if (NOT DEFINED CMAKE_AR)
+ set(CMAKE_AR "${CHOST_PREFIX}gcc-ar")
+ endif()
+ if (NOT DEFINED CMAKE_RANLIB)
+ set(CMAKE_RANLIB "${CHOST_PREFIX}gcc-ranlib")
+ endif()
+ else()
+ set(CMAKE_AR "gcc-ar")
+ set(CMAKE_RANLIB "gcc-ranlib")
endif()
endif()
endif()