aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2014-10-06 21:17:31 +0200
committerRiccardo Spagni <ric@spagni.net>2014-10-06 21:17:31 +0200
commitb05e27f8b1be83287441f82cb2f19a37aed2c1b6 (patch)
treeccda524dcb3c7730e3343bb480bc9c927a4908ea /CMakeLists.txt
parentset the winsock variable differently on Windows (diff)
downloadmonero-b05e27f8b1be83287441f82cb2f19a37aed2c1b6.tar.xz
need to link with -ldl on Linux when building statically
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 633a5e8d2..6db1a723d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,6 +217,7 @@ if(MINGW)
elseif(APPLE OR FREEBSD)
set(Boost_LIBRARIES "${Boost_LIBRARIES}")
elseif(NOT MSVC)
+ set(Boost_LIBRARIES "${Boost_LIBRARIES};ld")
#set(Boost_LIBRARIES "${Boost_LIBRARIES};rt;pthread")
endif()