aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfluffypony <ric@spagni.net>2014-09-10 14:19:42 +0200
committerfluffypony <ric@spagni.net>2014-09-10 14:19:42 +0200
commit81490d2aeae80ef3c3ab8ca209675ae2a950ac37 (patch)
tree859ad9d3173d90f007d5f304febc06f915106085 /CMakeLists.txt
parentmmap on FreeBSD doesn't have MAP_HUGETLB (diff)
downloadmonero-81490d2aeae80ef3c3ab8ca209675ae2a950ac37.tar.xz
miniupnpc changes for freebsd
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9614d7028..11273adca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,10 @@ else()
endif()
endif()
+if(NOT FREEBSD)
+ set(UPNP_LIBRARIES "upnpc-static")
+endif()
+
if(STATIC)
set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_STATIC_RUNTIME ON)