aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-10 21:11:18 -0400
committerredfish <redfish@galactica.pw>2016-07-10 21:27:00 -0400
commit19349d78705702b88202817d8c8e1a112f665da2 (patch)
treef6b0b9550b8ddca22ed98a45e61bd81e2436e635 /CMakeLists.txt
parentcmake: link with -latomic for clang (diff)
downloadmonero-19349d78705702b88202817d8c8e1a112f665da2.tar.xz
cmake: ARM: clang: make warning non-fatal: inline asm
Clang issues a warning for some inline asm in stack_trace.cpp. This patch ieaves the warning to be displayed as a reminder to fix the code.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b9deef55..365068516 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -323,6 +323,9 @@ else()
endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
set(WARNINGS "${WARNINGS} -Wno-error=mismatched-tags -Wno-error=null-conversion -Wno-overloaded-shift-op-parentheses -Wno-error=shift-count-overflow -Wno-error=tautological-constant-out-of-range-compare -Wno-error=unused-private-field -Wno-error=unneeded-internal-declaration")
+ if(ARM6 OR ARM7)
+ set(WARNINGS "${WARNINGS} -Wno-error=inline-asm")
+ endif()
else()
set(WARNINGS "${WARNINGS} -Wlogical-op -Wno-error=maybe-uninitialized")
endif()