aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-01-11 21:38:24 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-01-11 21:41:07 +0000
commitb7e5a70bb1a81d05cf4838f483c4618806f2b792 (patch)
tree745eb24c205c4a93cd311c85aad278a30e308c3a /CMakeLists.txt
parentMerge pull request #3091 (diff)
downloadmonero-b7e5a70bb1a81d05cf4838f483c4618806f2b792.tar.xz
epee: detect strptime, use std::get_time as fallback
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b27c10bd..a0508adfd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -868,5 +868,9 @@ option(INSTALL_VENDORED_LIBUNBOUND "Install libunbound binary built from source
CHECK_C_COMPILER_FLAG(-std=c11 HAVE_C11)
+include(CheckLibraryExists)
+include(CheckFunctionExists)
+
check_library_exists(c memset_s "string.h" HAVE_MEMSET_S)
check_library_exists(c explicit_bzero "strings.h" HAVE_EXPLICIT_BZERO)
+check_function_exists(strptime HAVE_STRPTIME)