aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2023-06-27 11:32:53 -0500
committerluigi1111 <luigi1111w@gmail.com>2023-06-27 11:32:53 -0500
commitdd5445d685a93702eb3e30d995b13cfc29b634a3 (patch)
tree5eb4a3f1dd6e333287aeb20efe249ed72f05f407 /CMakeLists.txt
parentMerge pull request #8792 (diff)
parentlink against libz on non Apple/Windows (diff)
downloadmonero-dd5445d685a93702eb3e30d995b13cfc29b634a3.tar.xz
Merge pull request #8795
724441a link against libz on non Apple/Windows (moneromooo-monero)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d036f7456..16d4a7e3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1113,7 +1113,8 @@ elseif(CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
set(EXTRA_LIBRARIES socket nsl resolv)
elseif(NOT MSVC AND NOT DEPENDS)
find_library(RT rt)
- set(EXTRA_LIBRARIES ${RT})
+ find_library(Z z)
+ set(EXTRA_LIBRARIES ${RT} ${Z})
endif()
list(APPEND EXTRA_LIBRARIES ${CMAKE_DL_LIBS})