aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2019-02-09 14:43:01 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-02-14 23:14:34 +0100
commit4a9257b46438b5fb8fe5d58ee8c3b2bbe2b826cc (patch)
treeec1a550b74a5369947b4ed313b0134201b6cc3af /CMakeLists.txt
parentMerge pull request #4988 (diff)
downloadmonero-4a9257b46438b5fb8fe5d58ee8c3b2bbe2b826cc.tar.xz
Support docker for gitian builds
Building with docker is arguably easier and more familiar to most people than either kvm, or lxc. This commit also relaxes the back compat requirement a bit. 32 bit linux now uses glibc version 2.0. Also, the docker shell could not handle gcc arguments containing spaces, so the explicit '-DFELT_TYPE' declaration was dropped. Lastly, this removes some packages from the osx descriptor.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31c3dbd21..f7cf56562 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -687,7 +687,6 @@ else()
endif()
if(BACKCOMPAT)
- add_definitions(-DFDELT_TYPE=long\ int)
add_linker_flag_if_supported(-Wl,--wrap=__divmoddi4 LD_BACKCOMPAT_FLAGS)
add_linker_flag_if_supported(-Wl,--wrap=glob LD_BACKCOMPAT_FLAGS)
message(STATUS "Using Lib C back compat flags: ${LD_BACKCOMPAT_FLAGS}")