aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Dorfman <ndorf@rtfm.net>2021-03-24 15:34:06 -0600
committerNathan Dorfman <ndorf@rtfm.net>2021-03-24 16:43:15 -0600
commit2d1fa5e0bab329bcb26e393240d4272797555822 (patch)
treeaa399bdb6462782bd401eca3a266c5808f54cdec /CMakeLists.txt
parentMerge pull request #7619 (diff)
downloadmonero-2d1fa5e0bab329bcb26e393240d4272797555822.tar.xz
cmake: Don't default to -march=native on OpenBSD
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49ac18c66..17776c05f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -554,6 +554,17 @@ endif()
# Trezor support check
include(CheckTrezor)
+# As of OpenBSD 6.8, -march=<anything> breaks the build
+function(set_default_arch)
+ if (OPENBSD)
+ set(ARCH default)
+ else()
+ set(ARCH native)
+ endif()
+
+ set(ARCH ${ARCH} CACHE STRING "CPU to build for: -march value or 'default' to not pass -march at all")
+endfunction()
+
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")
@@ -567,7 +578,7 @@ if(MSVC)
else()
include(TestCXXAcceptsFlag)
if (NOT ARCH)
- set(ARCH native CACHE STRING "CPU to build for: -march value or 'default' to not pass -march at all")
+ set_default_arch()
endif()
message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")
if(ARCH STREQUAL "default")