aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormj-xmr <mjxmr@protonmail.com>2021-05-14 15:29:57 +0200
committermj-xmr <mjxmr@protonmail.com>2021-05-14 15:29:57 +0200
commit0f45211c6b92b6ab676f2f49d9cef2b8fea85513 (patch)
tree5a0e0f39d2423a317b686fd0c2a224ac7d8e6f48 /CMakeLists.txt
parentMerge pull request #7697 (diff)
downloadmonero-0f45211c6b92b6ab676f2f49d9cef2b8fea85513.tar.xz
CMake: add *.inl to monero_find_all_headers() glob, along *.h*
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fecea318b..fbeca2574 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -168,11 +168,13 @@ endfunction()
#
# Parameters:
# - headers_found: Output variable, which will hold the found headers
-# - module_root_dir: The search path for the headers. Typically it will be the module's root dir.
+# - module_root_dir: The search path for the headers. Typically it will be the module's root dir, so "${CMAKE_CURRENT_SOURCE_DIR}" or a derivative of it.
macro (monero_find_all_headers headers_found module_root_dir)
file(GLOB ${headers_found}
"${module_root_dir}/*.h*" # h* will include hpps as well.
"${module_root_dir}/**/*.h*" # Any number of subdirs will be included.
+ "${module_root_dir}/*.inl" # .inl is typically template code and is being treated as headers (it's being included).
+ "${module_root_dir}/**/*.inl"
)
endmacro()