aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriDunk <0>2016-06-20 22:38:36 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-06-20 22:38:36 +0100
commit03e545d3232cf58ec94a815b381ae4e8e7f1e54a (patch)
tree23f0c215d85d52247240b8b53c51c3833a74af10 /CMakeLists.txt
parentCMakeLists.txt: fix build for mingw (diff)
downloadmonero-03e545d3232cf58ec94a815b381ae4e8e7f1e54a.tar.xz
More fixing for Windows
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d821cd88c..cb23beb5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -322,7 +322,7 @@ else()
endif()
if(MINGW)
set(WARNINGS "${WARNINGS} -Wno-error=unused-value -Wno-error=unused-but-set-variable")
- set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN")
+ set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN -D_POSIX_C_SOURCE")
set(Boost_THREADAPI win32)
include_directories(SYSTEM src/platform/mingw)
# mingw doesn't support LTO (multiple definition errors at link time)