aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Maryanov <acid@jack.kiev.ua>2017-10-10 14:05:28 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-11-14 17:03:48 +0000
commita17efcb039c1128fdb11fd147687f15f2ae12494 (patch)
treea01aa752a2183326286d8b81ec14c4e8697e4ecd /CMakeLists.txt
parentMerge pull request #2756 (diff)
downloadmonero-a17efcb039c1128fdb11fd147687f15f2ae12494.tar.xz
make this build on SunOS/Solaris
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 637e9c4e6..328e17646 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -331,6 +331,10 @@ if (UNIX AND NOT APPLE)
endif()
# Handle OpenSSL, used for sha256sum on binary updates and light wallet ssl http
+if (CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthreads")
+endif ()
+
if (APPLE AND NOT IOS)
if (NOT OpenSSL_DIR)
EXECUTE_PROCESS(COMMAND brew --prefix openssl
@@ -675,6 +679,8 @@ elseif(FREEBSD)
elseif(DRAGONFLY)
find_library(COMPAT compat)
set(EXTRA_LIBRARIES execinfo ${COMPAT})
+elseif(CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
+ set(EXTRA_LIBRARIES socket nsl resolv)
elseif(NOT MSVC)
find_library(RT rt)
set(EXTRA_LIBRARIES ${RT})