aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriDunk <0>2016-06-20 21:34:56 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-06-20 21:39:13 +0100
commite8baa5732692f9adbf5e833a1e6b1a055bd3174e (patch)
tree6f7dc2f3828fdea09cda3640afc305370b1a388f /CMakeLists.txt
parentMerge pull request #865 (diff)
downloadmonero-e8baa5732692f9adbf5e833a1e6b1a055bd3174e.tar.xz
CMakeLists.txt: fix build for mingw
Fix from iDunk from IRC.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09ca449d5..d821cd88c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -444,7 +444,7 @@ elseif(NOT MSVC)
set(EXTRA_LIBRARIES ${RT})
endif()
-if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND NOT MINGW)
find_library(DL dl)
set(EXTRA_LIBRARIES ${DL})
endif()