aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-09-18 17:07:54 +0200
committerTheCharlatan <seb.kung@gmail.com>2018-09-22 01:49:53 +0200
commitbf1e1d979c5efd0d1025b218342b553582e096d5 (patch)
treedd0e43f3f9b04cc8eb7546ac20106b041dde19ee /CMakeLists.txt
parentMerge pull request #4411 (diff)
downloadmonero-bf1e1d979c5efd0d1025b218342b553582e096d5.tar.xz
A Travis to monero
Add a Travis build script for Monero. This was blatantly copied from Bitcoin. It spawns jobs in docker containers running an ubuntu bionic image. This commit also a fixes a problem where librt was still linked, even when compiling statically.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a95e14b65..a018600fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -874,7 +874,7 @@ elseif(DRAGONFLY)
set(EXTRA_LIBRARIES execinfo ${COMPAT})
elseif(CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
set(EXTRA_LIBRARIES socket nsl resolv)
-elseif(NOT MSVC)
+elseif(NOT MSVC AND NOT DEPENDS)
find_library(RT rt)
set(EXTRA_LIBRARIES ${RT})
endif()