aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-08 22:34:43 -0400
committerredfish <redfish@galactica.pw>2016-07-09 11:59:07 -0400
commit1e89f4f2c56e6698d703a26f1281e3e57acecc50 (patch)
treed6e7abe3f551000ac02fbf62bf01c008f525da4d /CMakeLists.txt
parentMerge pull request #889 (diff)
downloadmonero-1e89f4f2c56e6698d703a26f1281e3e57acecc50.tar.xz
cmake: do not ignore dangerous warnings with -Wno-error
Shorten the list of warnings that are reported, but which are forced to NOT generate an error, via -Wno-error. Unwhitelist these: strict-aliasing, sign-compare, type-limits For example, ignoring strict-aliasing warning caused lots of wasted time diagnosing Issue #847.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b9c81895..c250b7ca4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -314,7 +314,7 @@ else()
set(ARCH_FLAG "-march=${ARCH}")
endif()
endif()
- set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=strict-aliasing -Wno-error=type-limits -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
+ set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
set(WARNINGS "${WARNINGS} -Wno-deprecated-register")
endif()