aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Kazenyuk <sergey@kazenyuk.com>2015-04-20 20:02:11 +0300
committerSergey Kazenyuk <sergey@kazenyuk.com>2015-04-20 20:02:11 +0300
commiteb565a1ce208c543392808559ddea709eb1c935b (patch)
tree36d40c4846a65326c31ad9cf59290f4bd5f4bc61 /CMakeLists.txt
parentversion bump to 0.8.8.6 (diff)
downloadmonero-eb565a1ce208c543392808559ddea709eb1c935b.tar.xz
Suppress 'register storage class is deprecated' warning in boost dependency library
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e5dfce75..a3d61daf3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,7 +155,7 @@ else()
else()
set(ARCH_FLAG "-march=${ARCH}")
endif()
- set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=strict-aliasing -Wno-error=type-limits -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
+ set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=strict-aliasing -Wno-error=type-limits -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized -Wno-deprecated-register")
if(NOT MINGW)
set(WARNINGS "${WARNINGS} -Werror")
endif()
@@ -257,4 +257,4 @@ add_subdirectory(src)
if(BUILD_TESTS)
add_subdirectory(tests)
-endif() \ No newline at end of file
+endif()