aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-23 14:04:08 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:35 -0400
commit9689df925c7e1b3291ad2f351136fee5f383f527 (patch)
tree8afec9ed1f290720c1825332ba66245e6f317a43 /CMakeLists.txt
parentcmake: set the project name (diff)
downloadmonero-9689df925c7e1b3291ad2f351136fee5f383f527.tar.xz
cmake: clean up EXTRA_LIBRARIES
pthread is handled by CMAKE_THREAD_LIBS_INIT while libdl isn't needed.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26a9ba8fb..7dcb36d85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -222,13 +222,11 @@ endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
if(MINGW)
- set(EXTRA_LIBRARIES pthread;mswsock;ws2_32)
+ set(EXTRA_LIBRARIES mswsock;ws2_32;iphlpapi)
elseif(APPLE OR FREEBSD)
set(EXTRA_LIBRARIES "")
elseif(NOT MSVC)
find_library(RT rt)
- find_library(PTHREAD pthread)
- find_library(DL dl)
set(EXTRA_LIBRARIES ${RT} ${PTHREAD} ${DL})
endif()