aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-07-20 14:24:50 +0200
committerRiccardo Spagni <ric@spagni.net>2016-07-20 14:24:50 +0200
commit39f7fad71d0a9fc72cab606ec1dfbd87dcda34ba (patch)
tree43e40825c17325405e8d6a090212c49397e9736c /CMakeLists.txt
parentMerge pull request #911 (diff)
downloadmonero-39f7fad71d0a9fc72cab606ec1dfbd87dcda34ba.tar.xz
fix duplicate clang block in cmake
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46c5b2e1d..c5514b221 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -315,14 +315,11 @@ else()
endif()
endif()
set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
- if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- set(WARNINGS "${WARNINGS} -Wno-deprecated-register")
- endif()
if(NOT MINGW)
set(WARNINGS "${WARNINGS} -Werror") # to allow pedantic but not stop compilation
endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- set(WARNINGS "${WARNINGS} -Wno-error=mismatched-tags -Wno-error=null-conversion -Wno-overloaded-shift-op-parentheses -Wno-error=shift-count-overflow -Wno-error=tautological-constant-out-of-range-compare -Wno-error=unused-private-field -Wno-error=unneeded-internal-declaration")
+ set(WARNINGS "${WARNINGS} -Wno-deprecated-register -Wno-error=mismatched-tags -Wno-error=null-conversion -Wno-overloaded-shift-op-parentheses -Wno-error=shift-count-overflow -Wno-error=tautological-constant-out-of-range-compare -Wno-error=unused-private-field -Wno-error=unneeded-internal-declaration")
if(ARM6 OR ARM7)
set(WARNINGS "${WARNINGS} -Wno-error=inline-asm")
endif()