aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorselsta <selsta@sent.at>2021-09-15 07:23:45 +0200
committerselsta <selsta@sent.at>2021-09-15 07:32:19 +0200
commit5617a292ee176f9282d8f50c229b501e3d351130 (patch)
tree2bf474b213a3749cfbbf2dc59dd8fe8179180eb9 /CMakeLists.txt
parentMerge pull request #7899 (diff)
downloadmonero-5617a292ee176f9282d8f50c229b501e3d351130.tar.xz
unbound: remove leftovers
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b9ba570d..6e85b719e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -384,18 +384,6 @@ endif()
message(STATUS "BOOST_IGNORE_SYSTEM_PATHS defaults to ${BOOST_IGNORE_SYSTEM_PATHS_DEFAULT}")
option(BOOST_IGNORE_SYSTEM_PATHS "Ignore boost system paths for local boost installation" ${BOOST_IGNORE_SYSTEM_PATHS_DEFAULT})
-
-if (NOT DEFINED ENV{DEVELOPER_LIBUNBOUND_OLD})
- message(STATUS "Could not find DEVELOPER_LIBUNBOUND_OLD in env (not required)")
-elseif ("$ENV{DEVELOPER_LIBUNBOUND_OLD}" EQUAL 1)
- message(STATUS "Found: env DEVELOPER_LIBUNBOUND_OLD = 1, will use the work around")
- add_definitions(-DDEVELOPER_LIBUNBOUND_OLD)
-elseif ("$ENV{DEVELOPER_LIBUNBOUND_OLD}" EQUAL 0)
- message(STATUS "Found: env DEVELOPER_LIBUNBOUND_OLD = 0")
-else()
- message(STATUS "Found: env DEVELOPER_LIBUNBOUND_OLD with bad value. Will NOT use the work around")
-endif()
-
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
enable_testing()
@@ -1242,10 +1230,6 @@ endif()
# when ON - will install libwallet_merged into "lib"
option(BUILD_GUI_DEPS "Build GUI dependencies." OFF)
-# This is not nice, distribution packagers should not enable this, but depend
-# on libunbound shipped with their distribution instead
-option(INSTALL_VENDORED_LIBUNBOUND "Install libunbound binary built from source vendored with this repo." OFF)
-
find_package(PythonInterp)
find_program(iwyu_tool_path NAMES iwyu_tool.py iwyu_tool)
if (iwyu_tool_path AND PYTHONINTERP_FOUND)