aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2014-09-17 15:17:31 -0400
committerRiccardo Spagni <ric@spagni.net>2014-09-23 22:58:02 +0200
commitdea98df6b1ae9a3f5b062f9d0be61e1fc1313b28 (patch)
tree8befc6cae00030d3a4db0077fb7c00f7de771399 /CMakeLists.txt
parentInitial commit of DNS code (diff)
downloadmonero-dea98df6b1ae9a3f5b062f9d0be61e1fc1313b28.tar.xz
Updated CMake files -- added libunbound linker flag
CMake config file written, but was unable to test/get it working properly because of a bug in CMake with functions related to find_package. Simple "-lunbound" flag used in its stead for now. May not build on non-Linux systems, not sure yet.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 875674733..6a2c66bc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -197,6 +197,11 @@ else()
add_custom_target(version ALL)
endif()
+# <expletive deleted> CMake bug making this not work.
+#find_package(Unbound REQUIRED)
+# Won't make sure this works, because that's broken.
+set(CMAKE_UNBOUND_LIB "-lunbound")
+
add_subdirectory(external)
# Final setup for miniupnpc