aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2014-12-01 20:00:22 +0200
committerRiccardo Spagni <ric@spagni.net>2014-12-01 20:00:22 +0200
commit685dd4a5d393e14a42f7ebb8adef75654b3ab6cc (patch)
tree305c92c2a251f0889ab1378a79dbb18e54f6685c /CMakeLists.txt
parentupdated readme to include libevent / libgtest deps (diff)
downloadmonero-685dd4a5d393e14a42f7ebb8adef75654b3ab6cc.tar.xz
don't build tests unless we're building all-* or *-test builds
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebca5c6fb..ee7bebdd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,4 +251,7 @@ endif()
include(version.cmake)
add_subdirectory(src)
-add_subdirectory(tests)
+
+if(BUILD_TESTS)
+ add_subdirectory(tests)
+endif() \ No newline at end of file