aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-04-07 14:27:37 -0400
committerThomas Winget <tewinget@gmail.com>2015-04-07 15:02:20 -0400
commit9519526224e02618313f5dff23de62923de55984 (patch)
tree8ed0f8116451bbecc3d00917722aecfe89b7e7c0 /CMakeLists.txt
parentMerge upstream into blockchain (diff)
downloadmonero-9519526224e02618313f5dff23de62923de55984.tar.xz
Only compile BerkeleyDB as an option in non-static
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92f8381cc..2f0494396 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -178,7 +178,9 @@ include_directories(external/rapidjson)
include_directories(${LMDB_INCLUDE})
# Final setup for Berkeley DB
-include_directories(${BDB_INCLUDE})
+if (NOT STATIC)
+ include_directories(${BDB_INCLUDE})
+endif()
if(MSVC)
add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")