aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Michaels <mikezackles@gmail.com>2014-06-12 15:38:28 -0400
committerZachary Michaels <mikezackles@gmail.com>2014-06-12 15:38:28 -0400
commit6bee34e4a67ee5c38b240e05a0f7c28d3ba4099f (patch)
tree211d8317eefd4c14aee5e12c31d47117650cd720 /CMakeLists.txt
parentLink to pthreads on non-apple unix (diff)
downloadmonero-6bee34e4a67ee5c38b240e05a0f7c28d3ba4099f.tar.xz
Fix to disable LTO for Clang
The previous code was assuming Apple == Clang. This change should both enable LTO when using gcc on Apple and fix Clang when using it on other platforms.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86a5267b2..6f084ba22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,7 +80,7 @@ else()
set(DEBUG_FLAGS "-g3 -O0")
endif()
set(RELEASE_FLAGS "-Ofast -DNDEBUG -Wno-unused-variable")
- if(NOT APPLE)
+ if(NOT CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# There is a clang bug that does not allow to compile code that uses AES-NI intrinsics if -flto is enabled
set(RELEASE_FLAGS "${RELEASE_FLAGS} -flto")
endif()