aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-28 23:26:51 -0400
committerredfish <redfish@galactica.pw>2016-07-28 23:26:51 -0400
commit35dc40af421c66f574cdba601c0bb995bc8978dc (patch)
treeb9ca14495904c432c75539badd13f9aa6bcd0a51 /CMakeLists.txt
parentcmake: cleanup logic that sets flags per target/subdir (diff)
downloadmonero-35dc40af421c66f574cdba601c0bb995bc8978dc.tar.xz
cmake: libatomic only needed for 32-bit Clang builds
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 964cd1fe2..93423462e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -470,11 +470,9 @@ endif()
list(APPEND EXTRA_LIBRARIES ${CMAKE_DL_LIBS})
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- if(NOT MINGW AND NOT APPLE)
- find_library(ATOMIC atomic)
- list(APPEND EXTRA_LIBRARIES ${ATOMIC})
- endif()
+if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32")
+ find_library(ATOMIC atomic)
+ list(APPEND EXTRA_LIBRARIES ${ATOMIC})
endif()
include(version.cmake)