aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-03-20 03:56:11 +0100
committerTheCharlatan <seb.kung@gmail.com>2018-09-10 22:05:37 +0200
commit5f7da005a3897184e9395c054da2ad8bed3e56bb (patch)
tree36fafc7f37b3f0fab70cffeec87d1e3dc844dbdf /CMakeLists.txt
parentUpdate readmes to reflect the usage of depends (diff)
downloadmonero-5f7da005a3897184e9395c054da2ad8bed3e56bb.tar.xz
Unbound is now a submodule. Adapt depends for this.
Fix builds for native linux and windows The architecture flag was set incorrectly. It needs to be set only when compiling arm6.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1fea6899..771b34949 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -487,7 +487,7 @@ if(MSVC)
include_directories(SYSTEM src/platform/msc)
else()
include(TestCXXAcceptsFlag)
- if (NOT DEPENDS)
+ if (NOT ARM6)
set(ARCH native CACHE STRING "CPU to build for: -march value or 'default' to not pass -march at all")
endif()
message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")