aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-12 00:25:56 -0400
committerredfish <redfish@galactica.pw>2016-07-12 00:25:56 -0400
commitf07f120e5d831323c70fd6c99690712cc430f371 (patch)
tree3a161384c8fad28e9e0895b3321810f7f32d0606 /CMakeLists.txt
parentcmake: ARM: clang: make warning non-fatal: inline asm (diff)
downloadmonero-f07f120e5d831323c70fd6c99690712cc430f371.tar.xz
cmake: don't try to link with atomic on Apple
-latomic is necessary with Clang on Linux, but apparently, on OSX it's not found.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 365068516..0525c190d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -460,7 +460,7 @@ endif()
list(APPEND EXTRA_LIBRARIES ${CMAKE_DL_LIBS})
-if(NOT MINGW)
+if(NOT MINGW AND NOT APPLE)
find_library(ATOMIC atomic)
list(APPEND EXTRA_LIBRARIES ${ATOMIC})
endif()