aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2017-12-15 18:44:01 +0100
committerGuillaume LE VAILLANT <glv@posteo.net>2017-12-15 18:44:01 +0100
commitdb2bc96512917c49dc6fa36058ef5fe9d4e66d16 (patch)
treef7ff01553df0407a0b14ef29620df81c48ec6637 /CMakeLists.txt
parentMerge pull request #2913 (diff)
downloadmonero-db2bc96512917c49dc6fa36058ef5fe9d4e66d16.tar.xz
Embed the translation files in the binary
If a translation file exists in a "translations" directory located in the same directory as the binary, it is used in priority (this can be useful when working on translations as you don't have to recompile the whole program all the time), and if no such file is found the embedded translation file is used (if it exists).
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d63b50510..8ff1d5909 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -355,6 +355,10 @@ endif()
add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
+# Generate header for embedded translations
+add_subdirectory(translations)
+include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+
add_subdirectory(external)
# Final setup for miniupnpc