aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoranonimal <anonimal@i2pmail.org>2016-08-16 12:59:15 +0000
committeranonimal <anonimal@i2pmail.org>2016-08-16 12:59:15 +0000
commit2a2b6550ad90cb6c2b4a74f21e9bd4e2cceecc6c (patch)
tree00ba9fc8e5a062ce3020fe8c53156546a29f35db /CMakeLists.txt
parentMerge pull request #955 (diff)
downloadmonero-2a2b6550ad90cb6c2b4a74f21e9bd4e2cceecc6c.tar.xz
Build: make boost 1.58 minimum requirement. Fixes #956
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90d06c12d..476736334 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -448,15 +448,11 @@ if(STATIC)
set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_STATIC_RUNTIME ON)
endif()
-find_package(Boost 1.53 QUIET REQUIRED COMPONENTS system filesystem thread date_time chrono regex serialization program_options)
+find_package(Boost 1.58 QUIET REQUIRED COMPONENTS system filesystem thread date_time chrono regex serialization program_options)
set(CMAKE_FIND_LIBRARY_SUFFIXES ${OLD_LIB_SUFFIXES})
if(NOT Boost_FOUND)
- die("Could not find Boost libraries, please make sure you have installed Boost or libboost-all-dev (1.53 or 1.55+) or the equivalent")
-endif()
-
-if((Boost_MAJOR_VERSION EQUAL 1) AND (Boost_MINOR_VERSION EQUAL 54))
- die("Boost version 1.54 is unsupported due to a bug (see: http://goo.gl/RrCFmA), please install Boost 1.53 or 1.55 and above")
+ die("Could not find Boost libraries, please make sure you have installed Boost or libboost-all-dev (1.58) or the equivalent")
endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})