aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfluffypony <ric@spagni.net>2014-09-10 13:25:34 +0200
committerfluffypony <ric@spagni.net>2014-09-10 13:25:34 +0200
commit0e343ecfdf862452933f2f5c10d4a93603a7de14 (patch)
tree9542fd9bf5ae87db8b23f74565c13470f0179eab /CMakeLists.txt
parentmore FreeBSD fixes (diff)
downloadmonero-0e343ecfdf862452933f2f5c10d4a93603a7de14.tar.xz
make FreeBSD use -lcompat till we can fix ftime()
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9614d7028..ea5a094f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,6 +130,10 @@ elseif(NOT MSVC)
set(Boost_LIBRARIES "${Boost_LIBRARIES};rt;pthread")
endif()
+if(FREEBSD)
+ set(BSD_COMPAT "compat")
+endif()
+
set(COMMIT_ID_IN_VERSION ON CACHE BOOL "Include commit ID in version")
file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/version")
if (NOT COMMIT_ID_IN_VERSION)