aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey <jeffryan@tamu.edu>2022-04-10 00:55:09 -0500
committerjeffro256 <jeffro256@tutanota.com>2023-07-02 19:29:18 -0500
commitce863683ab774177b5f4df3a16961316f89ddec9 (patch)
tree20c176e319a609074b86a1c68559ecd6ec8e31cf /CMakeLists.txt
parentMerge pull request #8884 (diff)
downloadmonero-ce863683ab774177b5f4df3a16961316f89ddec9.tar.xz
Remove src/platform
All the files in src/platform are currently unused and unnecessary. See below: * `mingw/alloca.h`: unused throughout project * `msc/sys/param.h`: 1. In `fix_darwin.patch`, `sys/param.h` is well-defined to be used only in OpenBSD environment 2. `int-util.h` already handles when `sys/param.h` is not present and injects its own values 3. `db_drivers/liblmdb/mdb.c` is a similar situation: already explicity handles different platforms 4. `src/crypto/chacha.h` uses `int-util.h` for endianness context * `msc/alloca.h`: unused * `msc/inline_c.h`: not needed. the `inline` keyword is supported for C99 I believe, and certainly for C11, C14+ * `msc/stdbool.h`: `stdbool.h` is standard since C99, and MSVC has supported it for a long time (~10 years)
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0c2ce378..1f634c114 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -701,7 +701,7 @@ endif()
include(CheckTrezor)
if(MSVC)
- add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /FIinline_c.h /D__SSE4_1__")
+ add_definitions("/bigobj /MP /W3 /GS- /D_CRT_SECURE_NO_WARNINGS /wd4996 /wd4345 /D_WIN32_WINNT=0x0600 /DWIN32_LEAN_AND_MEAN /DGTEST_HAS_TR1_TUPLE=0 /D__SSE4_1__")
# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /Dinline=__inline")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:10485760")
if(STATIC)
@@ -709,7 +709,6 @@ if(MSVC)
string(REPLACE "/MD" "/MT" ${VAR} "${${VAR}}")
endforeach()
endif()
- include_directories(SYSTEM src/platform/msc)
else()
include(TestCXXAcceptsFlag)
message(STATUS "Building on ${CMAKE_SYSTEM_PROCESSOR} for ${ARCH}")
@@ -786,7 +785,6 @@ else()
set(WARNINGS "${WARNINGS} -Wno-error=unused-value -Wno-error=unused-but-set-variable")
set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN")
set(Boost_THREADAPI win32)
- include_directories(SYSTEM src/platform/mingw)
# mingw doesn't support LTO (multiple definition errors at link time)
set(USE_LTO_DEFAULT false)
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--stack,10485760")