aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Michaels <mikezackles@gmail.com>2014-08-06 12:50:12 -0400
committerRiccardo Spagni <ric@spagni.net>2014-09-15 22:29:27 +0200
commit1b90c6f3d5d62c1929968266f6e920a4edf4fab6 (patch)
tree8dacd14e29f864b05d8014c2eb224ae5bff3e53e /CMakeLists.txt
parentChange to -static gcc flag (diff)
downloadmonero-1b90c6f3d5d62c1929968266f6e920a4edf4fab6.tar.xz
Hack to add pthread to link libraries on mingw
This should link winpthreads. We really shouldn't be passing these this way, but that seems to be the existing solution, and it works for now.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a87a03b9e..4f3806108 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,11 +150,11 @@ if((${Boost_MAJOR_VERSION} EQUAL 1) AND (${Boost_MINOR_VERSION} EQUAL 54))
endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
if(MINGW)
- set(Boost_LIBRARIES "${Boost_LIBRARIES};ws2_32;mswsock")
+ set(Boost_LIBRARIES "${Boost_LIBRARIES};pthread;mswsock;ws2_32")
elseif(APPLE OR FREEBSD)
set(Boost_LIBRARIES "${Boost_LIBRARIES}")
elseif(NOT MSVC)
- set(Boost_LIBRARIES "${Boost_LIBRARIES};rt;pthread")
+ #set(Boost_LIBRARIES "${Boost_LIBRARIES};rt;pthread")
endif()
file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/version")