summaryrefslogtreecommitdiff
path: root/net-p2p/monero
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero')
-rw-r--r--net-p2p/monero/files/0.15.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch46
-rw-r--r--net-p2p/monero/files/0.15.0.1-translations-use-host-compiler.patch30
-rw-r--r--net-p2p/monero/monero-0.15.0.1.ebuild13
3 files changed, 87 insertions, 2 deletions
diff --git a/net-p2p/monero/files/0.15.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch b/net-p2p/monero/files/0.15.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
new file mode 100644
index 00000000..3048cd7c
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
@@ -0,0 +1,46 @@
+From b2a20561f7a63634fc7951b24ef37e869de5b500 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 03:25:11 +0000
+Subject: [PATCH] https://sourceware.org/bugzilla/show_bug.cgi?id=25210
+
+---
+ CMakeLists.txt | 19 -------------------
+ 1 file changed, 19 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03e60cb1a475..cbf7232bd57b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -714,11 +714,6 @@ else()
+ CHECK_CXX_ACCEPTS_FLAG(-mfloat-abi=softfp CXX_ACCEPTS_MFLOAT_SOFTFP)
+ endif()
+
+- if(ARM8)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-835769 CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-843419 CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- endif()
+-
+ if(ARM6)
+ message(STATUS "Selecting VFP for ARMv6")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpu=vfp")
+@@ -755,20 +750,6 @@ else()
+ endif()
+ endif(ARM7)
+
+- if(ARM8)
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- message(STATUS "Enabling Cortex-A53 workaround 835769")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-835769")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-835769")
+- endif()
+-
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- message(STATUS "Enabling Cortex-A53 workaround 843419")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-843419")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-843419")
+- endif()
+- endif(ARM8)
+-
+ endif(ARM)
+
+ if(ANDROID AND NOT BUILD_GUI_DEPS STREQUAL "ON" OR IOS)
diff --git a/net-p2p/monero/files/0.15.0.1-translations-use-host-compiler.patch b/net-p2p/monero/files/0.15.0.1-translations-use-host-compiler.patch
new file mode 100644
index 00000000..a7c5499b
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.1-translations-use-host-compiler.patch
@@ -0,0 +1,30 @@
+From 0b95756dd331732f16ad28cee171a523946b160f Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03ede04837b5..03e60cb1a475 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -451,7 +451,12 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_C_COMPILER=$ENV{BUILD_CC}
++ -DCMAKE_CXX_COMPILER=$ENV{BUILD_CXX}
++ -DCMAKE_C_FLAGS=$ENV{BUILD_CFLAGS}
++ -DCMAKE_CXX_FLAGS=$ENV{BUILD_CXXFLAGS}
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)
diff --git a/net-p2p/monero/monero-0.15.0.1.ebuild b/net-p2p/monero/monero-0.15.0.1.ebuild
index a433664e..0ceca23e 100644
--- a/net-p2p/monero/monero-0.15.0.1.ebuild
+++ b/net-p2p/monero/monero-0.15.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{3_6,3_7} )
-CMAKE_MAKEFILE_GENERATOR="ninja"
+CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake-utils python-single-r1 user systemd
DESCRIPTION="Secure, private, untraceable cryptocurrency"
@@ -18,7 +18,7 @@ SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.t
LICENSE="NEWLIB"
SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="doc qt5 readline smartcard unwind"
+IUSE="doc qt5 nls readline smartcard unwind"
RDEPEND="net-dns/unbound:=[threads]
>=dev-libs/randomx-1.1.6:=
@@ -43,6 +43,7 @@ DEPEND="${PYTHON_DEPS}
media-gfx/graphviz
app-doc/doxygen:0
)
+ nls? ( dev-qt/qtchooser )
${RDEPEND}"
PDEPEND="qt5? ( net-p2p/monero-gui )"
@@ -53,6 +54,8 @@ PATCHES=(
"${FILESDIR}/${PV}-Use-gentoo-versioning.patch"
"${FILESDIR}/${PV}-Do-not-install-trezor-dep-libs.patch"
"${FILESDIR}/${PV}-Use-gentoo-dev-libs-randomx.patch"
+ "${FILESDIR}/${PV}-translations-use-host-compiler.patch"
+ "${FILESDIR}/${PV}-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch"
)
CMAKE_BUILD_TYPE=Release
@@ -75,6 +78,12 @@ src_unpack() {
fi
}
+src_prepare() {
+ cmake-utils_src_prepare
+
+ tc-export_build_env BUILD_C{C,XX}
+}
+
src_configure() {
local mycmakeargs=(
-DPYTHON_EXECUTABLE="${PYTHON}"