summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files')
-rw-r--r--net-p2p/monero/files/monero-0.18.0.0-Drop-in-tree-miniupnpc.patch60
-rw-r--r--net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-dev-libs-randomx.patch18
-rw-r--r--net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-versioning.patch37
-rw-r--r--net-p2p/monero/files/monero-0.18.0.0-translations-use-host-compiler.patch43
-rw-r--r--net-p2p/monero/files/monero-gui-0.18.0.0-cmake-use-gentoo-versioning.patch33
5 files changed, 191 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-0.18.0.0-Drop-in-tree-miniupnpc.patch b/net-p2p/monero/files/monero-0.18.0.0-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..4959cf9c
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.0.0-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,60 @@
+From dc3a18789e8c8ef6252bd94546bf8cd6184a56eb Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 17 Jun 2018 22:34:11 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+Since 6b8539803184 ("Build: update CMake and p2p for in-tree
+miniupnp"), a hard dependency is made on miniupnpc which is a git
+submodule not part of the archive available upstream.
+---
+ external/CMakeLists.txt | 19 +++----------------
+ src/p2p/net_node.inl | 6 +++---
+ 2 files changed, 6 insertions(+), 19 deletions(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 5b7f69a56843..fc40455064f4 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -36,22 +36,9 @@
+ # others.
+
+ find_package(Miniupnpc REQUIRED)
+-
+-message(STATUS "Using in-tree miniupnpc")
+-set(UPNPC_NO_INSTALL TRUE CACHE BOOL "Disable miniupnp installation" FORCE)
+-add_subdirectory(miniupnp/miniupnpc)
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-set_property(TARGET libminiupnpc-static PROPERTY POSITION_INDEPENDENT_CODE ON)
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
+-if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
+-endif()
+-
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++set(UPNP_STATIC false PARENT_SCOPE)
++set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index f33ce977de07..3d0c05a19da2 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -60,9 +60,9 @@
+ #include "cryptonote_core/cryptonote_core.h"
+ #include "net/parse.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
diff --git a/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-dev-libs-randomx.patch b/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-dev-libs-randomx.patch
new file mode 100644
index 00000000..178e83ff
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-dev-libs-randomx.patch
@@ -0,0 +1,18 @@
+From a007bfe93c3e71a166206abd30a91dc3637983c8 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Wed, 6 Nov 2019 01:23:52 +0000
+Subject: [PATCH] Use gentoo dev-libs/randomx
+
+---
+ external/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index fc40455064f4..5536debe8e2b 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -56,4 +56,3 @@ endif()
+ add_subdirectory(db_drivers)
+ add_subdirectory(easylogging++)
+ add_subdirectory(qrcodegen)
+-add_subdirectory(randomx EXCLUDE_FROM_ALL)
diff --git a/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-versioning.patch b/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-versioning.patch
new file mode 100644
index 00000000..c2c563e1
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.0.0-Use-gentoo-versioning.patch
@@ -0,0 +1,37 @@
+From 9e2da6c420843a4928b0fb42a41bafcfb4b95ee3 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 15 Jun 2019 00:15:54 +0100
+Subject: [PATCH] Use gentoo versioning
+
+---
+ cmake/Version.cmake | 18 +++---------------
+ 1 file changed, 3 insertions(+), 15 deletions(-)
+
+diff --git a/cmake/Version.cmake b/cmake/Version.cmake
+index e9ed9fba159b..5df4bc1ab7f3 100644
+--- a/cmake/Version.cmake
++++ b/cmake/Version.cmake
+@@ -31,20 +31,8 @@ function (write_version tag)
+ configure_file("${CMAKE_CURRENT_LIST_DIR}/../src/version.cpp.in" "${CMAKE_BINARY_DIR}/version.cpp")
+ endfunction ()
+
+-find_package(Git QUIET)
+-if ("$Format:$" STREQUAL "")
+- # We're in a tarball; use hard-coded variables.
+- set(VERSION_IS_RELEASE "true")
+- write_version("release")
+-elseif (GIT_FOUND OR Git_FOUND)
+- message(STATUS "Found Git: ${GIT_EXECUTABLE}")
+- include(GitVersion)
+- get_version_tag_from_git("${GIT_EXECUTABLE}")
+- write_version("${VERSIONTAG}")
+-else()
+- message(STATUS "WARNING: Git was not found!")
+- set(VERSION_IS_RELEASE "false")
+- write_version("unknown")
+-endif ()
++set(VERSION_IS_RELEASE "true")
++write_version("release")
++
+ add_custom_target(genversion ALL
+ DEPENDS "${CMAKE_BINARY_DIR}/version.cpp")
diff --git a/net-p2p/monero/files/monero-0.18.0.0-translations-use-host-compiler.patch b/net-p2p/monero/files/monero-0.18.0.0-translations-use-host-compiler.patch
new file mode 100644
index 00000000..e51bef2f
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.0.0-translations-use-host-compiler.patch
@@ -0,0 +1,43 @@
+From c927623016a946cddf6ba4e255cc9208929fa117 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 4 +++-
+ translations/CMakeLists.txt | 4 ++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b05c087cf898..ef980115c9e1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -671,7 +671,9 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_TOOLCHAIN_FILE=${CMAKE_CURRENT_BINARY_DIR}/translations.cmake
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND ${CMAKE_COMMAND} -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)
+diff --git a/translations/CMakeLists.txt b/translations/CMakeLists.txt
+index 3b43360f84c8..35fcae544a42 100644
+--- a/translations/CMakeLists.txt
++++ b/translations/CMakeLists.txt
+@@ -30,6 +30,10 @@ cmake_minimum_required(VERSION 3.5)
+
+ project(translations)
+
++# Ensure LDFLAGS for target are not propagated here since target are
++# meant for host
++UNSET(ENV{LDFLAGS})
++
+ # when crosscompiling import the executable targets from a file
+ IF(CMAKE_CROSSCOMPILING)
+ message(WARNING "CrossCompiling")
diff --git a/net-p2p/monero/files/monero-gui-0.18.0.0-cmake-use-gentoo-versioning.patch b/net-p2p/monero/files/monero-gui-0.18.0.0-cmake-use-gentoo-versioning.patch
new file mode 100644
index 00000000..1d05fdb6
--- /dev/null
+++ b/net-p2p/monero/files/monero-gui-0.18.0.0-cmake-use-gentoo-versioning.patch
@@ -0,0 +1,33 @@
+From 3a0d595e530779c37431743b73566a7f6b2543e9 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 18 Oct 2020 15:43:33 +0100
+Subject: [PATCH] cmake: use gentoo versioning
+
+---
+ cmake/VersionGui.cmake | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/cmake/VersionGui.cmake b/cmake/VersionGui.cmake
+index e225bf2bb3c0..1f8574e8d1e8 100644
+--- a/cmake/VersionGui.cmake
++++ b/cmake/VersionGui.cmake
+@@ -31,17 +31,7 @@ function (write_static_version_header tag)
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/src/version.js.in" "${CMAKE_CURRENT_SOURCE_DIR}/version.js")
+ endfunction ()
+
+-find_package(Git QUIET)
+-if ("$Format:$" STREQUAL "")
+- # We're in a tarball; use hard-coded variables.
+- write_static_version_header("release")
+-elseif (GIT_FOUND OR Git_FOUND)
+- message(STATUS "Found Git: ${GIT_EXECUTABLE}")
+- get_version_tag_from_git("${GIT_EXECUTABLE}")
+- write_static_version_header(${VERSIONTAG})
+-else()
+- message(STATUS "WARNING: Git was not found!")
+- write_static_version_header("unknown")
+-endif ()
++write_static_version_header("release")
++
+ add_custom_target(genversiongui ALL
+ DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/version.js")