summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.15.0.1.ebuild
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-11-21 23:01:04 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-11-27 22:58:58 +0000
commit2fa0a49a2a780294d8bb01bb22ae0cb604419d84 (patch)
treea0dfe1ae1fac8185365c6e927c06f86a01bd337b /net-p2p/monero/monero-0.15.0.1.ebuild
parentdev-libs/randomx: keyword ~arm64 (diff)
downloadportage-2fa0a49a2a780294d8bb01bb22ae0cb604419d84.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/monero-0.15.0.1.ebuild (renamed from net-p2p/monero/monero-0.15.0.0.ebuild)12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-p2p/monero/monero-0.15.0.0.ebuild b/net-p2p/monero/monero-0.15.0.1.ebuild
index dd45080f..a433664e 100644
--- a/net-p2p/monero/monero-0.15.0.0.ebuild
+++ b/net-p2p/monero/monero-0.15.0.1.ebuild
@@ -2,8 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils user systemd python-r1
+CMAKE_MAKEFILE_GENERATOR="ninja"
+inherit cmake-utils python-single-r1 user systemd
DESCRIPTION="Secure, private, untraceable cryptocurrency"
HOMEPAGE="https://getmonero.org"
@@ -18,8 +20,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="doc qt5 readline smartcard unwind"
-RDEPEND="dev-db/lmdb
- net-dns/unbound:=[threads]
+RDEPEND="net-dns/unbound:=[threads]
>=dev-libs/randomx-1.1.6:=
net-libs/miniupnpc:=
dev-libs/openssl:0
@@ -45,6 +46,8 @@ DEPEND="${PYTHON_DEPS}
${RDEPEND}"
PDEPEND="qt5? ( net-p2p/monero-gui )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
PATCHES=(
"${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch"
"${FILESDIR}/${PV}-Use-gentoo-versioning.patch"
@@ -55,6 +58,8 @@ PATCHES=(
CMAKE_BUILD_TYPE=Release
pkg_setup() {
+ python-single-r1_pkg_setup
+
enewgroup monero
enewuser monero -1 -1 /var/lib/monero monero
}
@@ -72,6 +77,7 @@ src_unpack() {
src_configure() {
local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
-DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
-DBUILD_TESTS=OFF
-DCOVERAGE=OFF