summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.14.0.2.ebuild
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-03-10 13:24:36 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-03-10 13:24:36 +0000
commit3475096a717a2839865b863068fdfd28af4e66ef (patch)
tree265c3c6d07918a35794bc2f963f20c46296c3821 /net-p2p/monero/monero-0.14.0.2.ebuild
parentprofiles/server: Bump www-apps/nextcloud keyword (diff)
downloadportage-3475096a717a2839865b863068fdfd28af4e66ef.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/monero-0.14.0.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-p2p/monero/monero-0.14.0.2.ebuild b/net-p2p/monero/monero-0.14.0.2.ebuild
new file mode 100644
index 00000000..9231e766
--- /dev/null
+++ b/net-p2p/monero/monero-0.14.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://getmonero.org"
+SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc qt5 readline smartcard unwind"
+
+RDEPEND="dev-db/lmdb
+ net-dns/unbound:=[threads]
+ net-libs/miniupnpc:=
+ dev-libs/openssl:0
+ dev-libs/boost:=
+ net-libs/zeromq:=[sodium]
+ net-libs/cppzmq:=
+ dev-libs/rapidjson:=
+ net-libs/openpgm:=
+ readline? ( sys-libs/readline:= )
+ unwind? ( sys-libs/libunwind[lzma] )
+ smartcard? ( dev-libs/hidapi:= )"
+DEPEND=">=dev-util/cmake-3.5
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen:0
+ )
+ ${RDEPEND}"
+PDEPEND="qt5? ( net-p2p/monero-gui )"
+
+PATCHES=( "${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch" )
+
+CMAKE_BUILD_TYPE=Release
+
+src_configure () {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
+ -DBUILD_TESTS=OFF
+ -DCOVERAGE=OFF
+ -DUSE_READLINE="$(usex readline ON OFF)"
+ -DBUILD_GUI_DEPS="$(usex qt5 ON OFF)"
+ -DINSTALL_VENDORED_LIBUNBOUND=OFF
+ )
+
+ export DATABASE="lmdb"
+ export DEVELOPER_LOCAL_TOOLS=0
+ export DEVELOPER_LIBUNBOUND_OLD=0
+
+ cmake-utils_src_configure
+}