summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.11.1.0.ebuild
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-12-10 14:00:47 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-03-07 01:30:06 +0000
commit481d1a3f8626be6d1c75271b5e282a2b211d7085 (patch)
tree4c4199e4f81f4996167c85f290ae819f27005009 /net-p2p/monero/monero-0.11.1.0.ebuild
parentnet-p2p/pesetacoin: Pesetacoin is a crypto-currency focused in the Spanish Co... (diff)
downloadportage-481d1a3f8626be6d1c75271b5e282a2b211d7085.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/monero-0.11.1.0.ebuild (renamed from net-p2p/monero/monero-0.11.0.0.ebuild)20
1 files changed, 14 insertions, 6 deletions
diff --git a/net-p2p/monero/monero-0.11.0.0.ebuild b/net-p2p/monero/monero-0.11.1.0.ebuild
index 70c5e0dd..a93f9acf 100644
--- a/net-p2p/monero/monero-0.11.0.0.ebuild
+++ b/net-p2p/monero/monero-0.11.1.0.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils
-DESCRIPTION="Monero: the secure, private, untraceable cryptocurrency"
+DESCRIPTION="Secure, private, untraceable cryptocurrency"
HOMEPAGE="https://getmonero.org"
SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="NEWLIB"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc readline +system-libs unwind"
+KEYWORDS="~amd64"
+IUSE="doc qt5 readline +system-libs unwind"
RDEPEND="dev-db/lmdb
system-libs? (
net-dns/unbound
- net-libs/miniupnpc )
+ net-libs/miniupnpc
+ )
dev-libs/openssl:0
dev-libs/boost:=
readline? ( sys-libs/readline:= )
@@ -25,8 +26,10 @@ RDEPEND="dev-db/lmdb
DEPEND=">=dev-util/cmake-2.8.7
doc? (
media-gfx/graphviz
- app-doc/doxygen:0 )
+ app-doc/doxygen:0
+ )
${RDEPEND}"
+PDEPEND="qt5? ( =net-p2p/monero-gui-${PV} )"
PATCHES=( "${FILESDIR}/${PV}-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch" )
@@ -38,7 +41,12 @@ src_configure () {
-DCOVERAGE=OFF
-DUSE_READLINE="$(usex readline ON OFF)"
-DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
+ -DBUILD_GUI_DEPS="$(usex qt5 ON OFF)"
)
+ export DATABASE="lmdb"
+ export DEVELOPER_LOCAL_TOOLS=0
+ export DEVELOPER_LIBUNBOUND_OLD=0
+
cmake-utils_src_configure
}