summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.11.0.0.ebuild
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-10-15 22:59:49 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-01-15 21:40:08 +0000
commit533da49af4ce34e625e7e057e87242b854285dbd (patch)
treeb8f97b086eb2ced30c352f58af5df16c2903e887 /net-p2p/monero/monero-0.11.0.0.ebuild
parentdev-python/hidapi: Version bump (diff)
downloadportage-533da49af4ce34e625e7e057e87242b854285dbd.tar.xz
net-p2p/monero: Monero: the secure, private, untraceable cryptocurrency
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/monero-0.11.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/monero/monero-0.11.0.0.ebuild b/net-p2p/monero/monero-0.11.0.0.ebuild
new file mode 100644
index 00000000..70c5e0dd
--- /dev/null
+++ b/net-p2p/monero/monero-0.11.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Monero: the secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://getmonero.org"
+SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc readline +system-libs unwind"
+
+RDEPEND="dev-db/lmdb
+ system-libs? (
+ net-dns/unbound
+ net-libs/miniupnpc )
+ dev-libs/openssl:0
+ dev-libs/boost:=
+ readline? ( sys-libs/readline:= )
+ net-libs/zeromq[sodium]
+ unwind? ( sys-libs/libunwind[lzma] )"
+DEPEND=">=dev-util/cmake-2.8.7
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen:0 )
+ ${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch" )
+
+src_configure () {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
+ -DBUILD_TESTS=OFF
+ -DCOVERAGE=OFF
+ -DUSE_READLINE="$(usex readline ON OFF)"
+ -DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
+ )
+
+ cmake-utils_src_configure
+}